Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 22, 2026 - 08:00 IST
Scheduled
DPD Ireland has given advance notice that scheduled maintenance is planned on Wednesday July 22nd from 08:00 to 09:00.
Purpose of Maintenance: This maintenance will introduce DPD Ireland's new PickUp Locker location map feature and further enhance our system security and efficiency. This maintenance will impact Location Map, Managed Delivery and customer portal functions.
What does this mean for Scurri customers: During the period of maintenance label generation may be impacted.
Posted Jul 21, 2026 - 08:51 IST
This scheduled maintenance affected: Scurri Platform API and Scurri front-end.