Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 04, 2026 - 19:00 GMT
Scheduled
DPD Ireland has given notice that scheduled maintenance is planned for 04/03/26 from 7 p.m. to 10 p.m. GMT
Purpose of Maintenance: DPD anticipates no disruption to its services during this period. This proactive measure is designed to further enhance the stability and efficiency of its systems.
Posted Mar 04, 2026 - 15:25 GMT
This scheduled maintenance affected: Scurri Platform API.