Issue with Landmark service

Incident Report for Scurri

Resolved

This incident has been resolved and we an see that Landmark labels are being generated successfully.
Posted Nov 06, 2025 - 12:08 GMT

Investigating

We have identified an issue with Landmark services and are currently investigating.

Please check back here for updates on this issue.
Posted Nov 06, 2025 - 10:33 GMT
This incident affected: Scurri Platform API and Scurri front-end.