Issue with DPD services
Incident Report for Scurri
Resolved
DPD have confirmed that they were experiencing network issues on their end, and their Infrastructure team have now resolved the issue.

We will continue to monitor over the next while to make sure that there are no further issues.

If you experience any issues please don't hesitate to contact our support team at support@scurri.com
Posted Oct 18, 2021 - 15:01 IST
Investigating
We have identified an issue with DPD services and are currently investigating.

If you're experiencing any issues, please contact support@scurri.com

Please check back here for updates on this issue.
Posted Oct 18, 2021 - 09:45 IST
This incident affected: Scurri Platform API and Scurri front-end.