Issue with DHL service
Incident Report for Scurri
Resolved
This incident has been resolved.
Posted Dec 15, 2023 - 14:38 GMT
Investigating
We have identified an issue with DHL services and are currently investigating.

If you're experiencing any issues, please contact support@scurri.com

Please check back here for updates on this issue.
Posted Dec 15, 2023 - 11:37 GMT
This incident affected: Scurri Platform API and Scurri front-end.