DPD UK Intermittent issues.
Incident Report for Scurri
Resolved
This incident has been resolved.
Posted Nov 23, 2020 - 17:28 GMT
Investigating
DPD UK is experiencing intermittent issues, generating labels. If you receive an error "Unable to contact DPD service", please retry. DPD UK is currently investigating the issue.
Posted Nov 17, 2020 - 15:28 GMT