Amazon Shipping - Label Generation Issue
Incident Report for Scurri
Resolved
This issue has been resolved and Amazon Shipping is working as expected.
Posted Jan 21, 2025 - 12:57 GMT
Investigating
We are currently investigating an issue with Amazon Shipping where some customers are reporting that they are unable to produce an Amazon shipping label. Please monitor the Scurri status page for updates.
Posted Jan 21, 2025 - 09:23 GMT
This incident affected: Scurri front-end.