Issue with P2P service when shipping to Ireland
Incident Report for Scurri
Resolved
This incident has been resolved.
Posted May 20, 2020 - 08:59 IST
Investigating
P2P have identified an issue with there services when shipping to Ireland and currently investigating.

If you're experiencing any issues, please contact support@scurri.com

Please check back here for updates on this issue.
Posted May 19, 2020 - 11:55 IST
This incident affected: API and Scurri front-end.