Issues with DX

Incident Report for Scurri

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 12:12 IST

Investigating

We are aware of issues being reported with DX at the moment. We have reached out to the carrier to get further information.

Updates will be provided as DX shares them with us.

You can also check in on the DX portal for any updates.
Posted Jun 18, 2026 - 09:55 IST
This incident affected: Scurri Platform API.