Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 10, 2026 - 15:00 IST
Scheduled
Please be advised that DPD will conduct scheduled system updates to deploy new services.
Date: Thursday, September 10th Time: 15:00 – 17:00
While DPD does not anticipate any service disruptions during this time, they are notifying you as a precaution in the unlikely event of a brief service interruption.
Posted Sep 10, 2026 - 08:09 IST
This scheduled maintenance affected: Scurri Platform API.