Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 25, 2024 - 03:00 IST
Scheduled
Deutsche Post has given advance notice that scheduled maintenance is planned on Tuesday June 25th 03:00 to 04:00 GMT - The maintenance will impact the following services:
Parcel Germany (DHL) │ Returns │ Returns international (api-eu.dhl.com) │ Returns international (cig.dhl.de)
Purpose of Maintenance: Server maintenance
What does this mean for Scurri customers: During the period of maintenance label generation and tracking will be impacted.
Posted Jun 18, 2024 - 10:11 IST
This scheduled maintenance affected: Scurri Platform API and Scurri front-end.