Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 05, 2024 - 05:00 GMT
Scheduled
Deutsche Post has given advance notice that scheduled maintenance is planned on Tuesday November 5th from 06:00 to 07:00 CEST - This maintenance will impact the Deusche Post Internetmarke service
Purpose of Maintenance: Planned Maintenance
What does this mean for Scurri customers: During the period of maintenance label generation will be impacted.
Posted Nov 04, 2024 - 13:12 GMT
This scheduled maintenance affected: Scurri Platform API and Scurri front-end.