Issue with DPD services

Incident Report for Scurri

Resolved

DPD has resolved this incident.

DPD confirmed that a change was implemented yesterday evening to resolve the issue, and full service has been restored.
Posted Sep 23, 2025 - 10:49 IST

Monitoring

While we await an update from DPD to confirm the issue is resolved, our monitoring indicates that labels can be successfully generated again.

We will continue to monitor and confirm full resolution as soon as we hear back from DPD.
Posted Sep 22, 2025 - 19:23 IST

Update

DPD are continuing to work on a resolution.

We will provide another update as soon as we have further information.
Posted Sep 22, 2025 - 17:31 IST

Identified

DPD have identified the cause of the issue and is implementing a fix.

ETA is within the next 30 minutes.

We will update you again shortly.
Posted Sep 22, 2025 - 16:08 IST

Investigating

We have identified an issue with DPD services and have raised this with DPD.

They are currently investigating.

We will update you as soon as we have futher information
Posted Sep 22, 2025 - 15:31 IST
This incident affected: Scurri Platform API and Scurri front-end.