Issue with DPD UK services

Incident Report for Scurri

Resolved

We have monitored DPD and can confirm that the issue now looks to be resolved.

If you are experiencing any issues, please contact support@scurri.com
Posted Feb 06, 2025 - 11:35 GMT

Monitoring

It's been confirmed by DPD that they have resolved the issue, and labels are now generating successfully. We will continue to monitor over the next while to make sure that the issue does not occur again

If you're still experiencing any issues, please contact support@scurri.com
Posted Feb 05, 2025 - 13:58 GMT

Identified

DPD has confirmed that the issue with the service is on their end and is currently being looked into as a matter of urgency.

If you're experiencing any issues, please contact support@scurri.com

Please check back here for updates on this issue.
Posted Feb 05, 2025 - 09:56 GMT

Investigating

We have identified an issue with DPD UK services and are currently investigating.

If you're experiencing any issues, please contact support@scurri.com

Please check back here for updates on this issue.
Posted Feb 05, 2025 - 09:16 GMT
This incident affected: Scurri Platform API and Scurri front-end.