Intermittent issues with DPD Ireland services
Incident Report for Scurri
Resolved
DPD has resolved the intermittent timeout issues, and labels are generating again successfully

If you are still experiencing issues, please don't hesitate to contact our support team at support@scurri.com
Posted Jun 12, 2024 - 10:29 IST
Identified
We have identified an intermittent issue when connecting to DPD Ireland's server to generate labels. DPD confirmed that they are aware of internet connectivity issues, and their network provider is currently working on the issue.

As soon as we have an update we will update this incident.
Posted Jun 11, 2024 - 17:13 IST
This incident affected: Scurri Platform API and Scurri front-end.