Issue with DHL Express service

Incident Report for Scurri

Resolved

DHL has resolved the service degradation issue that customers experienced today.

Labels can now be successfully generated.
Posted Dec 15, 2023 - 15:45 GMT

Investigating

We have identified an issue with generating DHL Express labels and this has been raised with DHL for investigation.

As soon as we have further information we will update this incident.
Posted Dec 15, 2023 - 11:39 GMT
This incident affected: Scurri Platform API and Scurri front-end.