Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 10, 2026 - 06:00 IST
Scheduled
Deutsche Post International has made us aware of planned maintenance with temporary impairments.
The maintenance is scheduled to take place on 2026-06-07 from 08:00 CEST to 2026-06-07 10:00 CEST
Affected services auf IT Service Post Paket Deutschland Status:
Deutsche Post International │ Customer Portal - Deutsche Post International │ Shipping API - Deutsche Post International │ Tracking API - Deutsche Post International
Posted Jun 09, 2026 - 08:30 IST
This scheduled maintenance affected: Scurri Platform API.