Issue with Evri service

Incident Report for Scurri

Resolved

Evri has confirmed that they have identified and resolved this issue.

Please let us know if you experience any further issues.
Posted Oct 29, 2025 - 13:19 GMT

Monitoring

We have seen the recovery of the Evri services in the last 15 minutes.

We are awaiting an update from Evri, and will continue to monitor performance.
Posted Oct 29, 2025 - 13:11 GMT

Investigating

We have identified an issue with Evri services and have raised this with the Evri Service Desk.

We do not currently have an ETA.

We will keep you updated as we hear more from Evri.

Please check back here for updates on this issue.
Posted Oct 29, 2025 - 12:48 GMT
This incident affected: Scurri Platform API and Scurri front-end.