Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 20, 2024 - 07:00 IST
Scheduled
Deutsche Post has given advance notice that scheduled maintenance is planned on their International Shipping and Tracking API on Sunday October 20th from 08:00 to 10:00 CEST
Purpose of Maintenance: Minor changes to the production environment.
What does this mean for Scurri customers: During the period of maintenance label generation may be impacted.
Posted Oct 18, 2024 - 13:19 IST
This scheduled maintenance affected: Scurri Platform API and Scurri front-end.