Issue with DPD services

Incident Report for Scurri

Resolved

This incident has been resolved.
Posted Nov 10, 2025 - 16:00 GMT

Investigating

We have identified an issue with DPD services and are currently investigating.

This incident has been resolved and we an see that Landmark labels are being generated successfully.
Posted Nov 10, 2025 - 12:34 GMT