Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 28, 2024 - 07:00 GMT
Scheduled
Deutsche Post has given advance notice that scheduled maintenance is planned their INTERNETMARKE and Mobile Briefmarke services on Sunday January 28th 8:00am to 8:30am (CET)
Purpose of Maintenance: Scheduled Maintenance
What does this mean for Scurri customers: During the period of maintenance the INTERNETMARKE and Mobile Briefmarke services will not be available.
Posted Jan 19, 2024 - 12:45 GMT
This scheduled maintenance affected: Scurri Platform API and Scurri front-end.