DPD Ireland Customer Portal System Outage

Incident Report for Scurri

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 10:50 IST

Investigating

DPD Ireland has advised that they are currently experiencing intermittent technical issues with their API services (including Customer Portal) which may affect your service. The DPD IT Team is aware and actively pursuing an immediate resolution.

Updates will be provided as DPD share them with us.
Posted Apr 16, 2026 - 10:18 IST
This incident affected: Scurri Platform API.