Royal Mail service issue
Incident Report for Scurri
Resolved
This incident has been resolved.
Posted Jun 09, 2020 - 09:16 IST
Identified
Royal Mail have advised of an issue with their services and are currently investigating.

Please check back here for updates on this issue, as we will post an update as soon as we receive one from Royal Mail.

This will not affect your printing of labels or collections.
Posted Jun 08, 2020 - 15:58 IST
This incident affected: Scurri Platform API and Scurri front-end.