Scurri Zendesk Platform Incident Identified

Incident Report for Scurri

Resolved

Cloudflare have resolved the issue and Zendesk is now fully functional again.

If you have any issues please contact us at support@scurri.com or call Support | +44 20 3807 6800 | +353 51 625 624
Posted Dec 05, 2025 - 09:21 GMT

Update

We have identified that the Zendesk issues is being caused by a system failure on Cloudflare.

Cloudflare are aware and are working on the issue.
Posted Dec 05, 2025 - 08:59 GMT

Identified

We have identified an issue within the Zendesk Platform used by the Scurri support team.

We are currently investigating and will update this post with further information when available.

For urgent issues please call Support | +44 20 3807 6800 | +353 51 625 624
Posted Dec 05, 2025 - 08:54 GMT
This incident affected: Scurri Platform API and Scurri front-end.