Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 13, 2024 - 05:00 GMT
Scheduled
Deutsche Post has given advance notice that scheduled maintenance is planned on Wednesday November 13th from 06:00 to 07:00 CET. This will impact their INTERNETMARKE services
Purpose of Maintenance: Planned Maintenance
What does this mean for Scurri customers: During the period of maintenance label generation will be impacted.
Posted Nov 12, 2024 - 11:18 GMT
This scheduled maintenance affected: Scurri Platform API and Scurri front-end.