Issue with DPD services
Incident Report for Scurri
Resolved
This incident has been resolved.

DPD are no longer experiencing issues with the service.

If you're experiencing any issues, please contact us via support@scurri.com to make us aware of it.
Posted Oct 16, 2017 - 16:26 IST
Investigating
DPD and DPD Local (Interlink) are currently experiencing issues and are investigating.

We do not currently have an ETA.

Please check back here for updates on this issue.
Posted Oct 16, 2017 - 15:13 IST