Incident Identifed
Incident Report for Scurri
Resolved
We have resolved the issue that was affecting our User Interface.

You can refresh your Browser and our User Interface will operate as normal.
Posted Jan 11, 2017 - 17:25 GMT
Identified
We have identified an issue within the Scurri User Interface which will effect Customers.

Our Team are currently fixing this issue

If you're experiencing any issues, please contact us via support@scurri.com to make us aware of it.
Posted Jan 11, 2017 - 17:05 GMT