CN22/23 Document Issues
Incident Report for Scurri
Resolved
This incident has been resolved.
Posted Jan 12, 2021 - 08:12 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 11, 2021 - 16:58 GMT
Investigating
We are currently investigating issues where the CN22 is being printed on shipments for mainland UK. This document is not necessary for mainland UK. This status will be updated with further information
Posted Jan 11, 2021 - 16:34 GMT
This incident affected: Scurri Platform API and Scurri front-end.