Issue with DHL DE service
Incident Report for Scurri
Resolved
DHL DE has confirmed that the issue has been resolved on their side.

Labels are now being produced again
Posted Sep 16, 2020 - 15:33 IST
Identified
DHL have identified an issue with DHL DE services and currently investigating.

If you're experiencing any issues, please contact support@scurri.com

Please check back here for updates on this issue.
Posted Sep 15, 2020 - 14:00 IST