Scurri Incident Identified

Incident Report for Scurri

Resolved

This incident has been resolved.

If you're experiencing any issues, please contact us via support@scurri.com to make us aware of it.
Posted Nov 27, 2025 - 06:42 GMT

Investigating

We have identified an issue within the Scurri platform impacting order creation and label generation.

We are currently investigating as a matter of urgency and will update this post with further information as soon as possible
Posted Nov 27, 2025 - 06:24 GMT
This incident affected: Scurri Platform API and Scurri front-end.