Intermittent connectivity Issue with FedEx services
Incident Report for Scurri
Resolved
FedEx have confirmed that the issues processing international shipments have now been resolved

We will continue to monitor, but if you experience any further issues please don't hesitate to contact us here within support at support@scurri.com
Posted Sep 24, 2021 - 16:38 IST
Identified
We have identified an intermittent issue with FedEx services where the connection is intermittently timing out when requesting a label.

FedEx confirmed that they are aware of an issue on their side and are investigating it further

Please check back here for updates on this issue.
Posted Sep 21, 2021 - 11:10 IST