Issue with DPI service
Incident Report for Scurri
Resolved
This incident has now been resolved by DPI
Posted Apr 08, 2020 - 15:30 IST
Investigating
DPI have identified an issue with their services and currently investigating.

If you're experiencing any issues, please contact support@scurri.com

Please check back here for updates on this issue.
Posted Apr 08, 2020 - 14:55 IST
This incident affected: Scurri Platform API and Scurri front-end.