Issue with UPS service
Incident Report for Scurri
Resolved
This incident has been resolved.
Posted Jun 08, 2020 - 18:37 IST
Identified
We have identified an issue with UPS services. UPS are currently investigating.

This will affect the manifesting of your shipments.

If you're experiencing any issues, please contact support@scurri.com

Please check back here for updates on this issue.
Posted Jun 08, 2020 - 17:58 IST
This incident affected: API and Scurri front-end.