Issue with Deutsche Post services
Incident Report for Scurri
Resolved
A fix for this issue was deployed this evening and normal service has resumed for the Deutsche Post Services.
Posted May 16, 2022 - 22:00 IST
Identified
We have identified an issue with Deutsche Post.

We are currently implementing a fix and will update you again shortly once this has been deployed.

Please check back here for updates on this issue.
Posted May 16, 2022 - 16:52 IST
This incident affected: Scurri Platform API and Scurri front-end.