DHL loss of service
Incident Report for Scurri
Resolved
DHL have advised that their outage has now been resolved.

All services should be available again.
Posted Apr 26, 2017 - 16:54 IST
Identified
DHL are currently experiencing technical issues. Their team is working to resolve this as quickly as possible.

We will update this incident when we have more information.
Posted Apr 26, 2017 - 16:35 IST