Deutsche Post International service issue
Incident Report for Scurri
Resolved
This incident has been resolved.
Posted Oct 14, 2019 - 10:38 IST
Investigating
Deutsche Post International has advised that the issue with their API has now been resolved.

If you are still experiencing issues please contact support.
Posted Oct 14, 2019 - 09:34 IST
This incident affected: Scurri Platform API and Scurri front-end.