Issue with DPD Ireland services
Incident Report for Scurri
Resolved
This incident has been resolved.
Posted Apr 01, 2020 - 15:40 IST
Update
We are continuing to investigate this issue.
Posted Apr 01, 2020 - 14:40 IST
Investigating
We have identified an issue with DPD Ireland services and currently investigating.

If you're experiencing any issues, please contact support@scurri.com

Please check back here for updates on this issue.
Posted Apr 01, 2020 - 14:39 IST
This incident affected: Scurri Platform API and Scurri front-end.