Issue with DHL service
Incident Report for Scurri
Resolved
This incident has been resolved.

If you're experiencing any issues, please contact us via support@scurri.com to make us aware of it.
Posted Apr 24, 2017 - 12:01 IST
Investigating
We are currently investigating an issue with DHL services.

If you're experiencing any issues, please contact support@scurri.com

Please check back here for updates on this issue.
Posted Apr 24, 2017 - 09:48 IST