Loss of service
Incident Report for Scurri
Postmortem

The cause of the incident has been analysed and the findings were as follows:

In the course of the deployments, a code library element caused an interaction that brought down the mechanism we use to queue up imports of shipments, api creation of shipments and some other activities.

We rolled the change back, corrected the library element and brought the systems back online.

To mitigate against future incidents we’re adding new validations to our tests to catch this in every future deployment.

Posted Apr 18, 2017 - 08:57 IST

Resolved
We have resolved the partial loss of service. The rollback was successful and all services are running again.

We will publish a full post-mortem of the incident as soon as we gather all the information.

We apologise for the loss of service.
Posted Apr 14, 2017 - 12:01 IST
Monitoring
Our engineering team have rolled back the release.

We're currently testing and monitoring the change.
Posted Apr 14, 2017 - 11:48 IST
Update
We have identified the partial loss of service as an issue introduced by a new release.

We are currently rolling back to the previous release
Posted Apr 14, 2017 - 11:43 IST
Identified
Please be aware that a portion of our customers are experiencing a loss of service.

We will update this status as soon as more information is available.
Posted Apr 14, 2017 - 11:33 IST